Lag on Cohofutag I, Letiomopas II, Kai I, possibly others

Incident Report for Playable Worlds

Resolved

Restarts of all impacted servers are complete and we have logged into each to check them.
Posted Aug 21, 2026 - 07:09 UTC

Monitoring

We have logged into each of the affected servers and verified that performance is back to normal.
Posted Aug 21, 2026 - 07:02 UTC

Update

All the rebooted servers are back up cleanly.
Posted Aug 21, 2026 - 07:00 UTC

Update

We are continuing to reset servers; the first two came back up healthy.
Posted Aug 21, 2026 - 06:32 UTC

Identified

A cause for the issue has been identified and we have a code fix. We will be getting it out to game servers as soon as possible after testing.
Posted Aug 21, 2026 - 06:21 UTC

Update

We are resetting Haven, Letiemopas II, and Cohofutag I and II.
Posted Aug 21, 2026 - 06:17 UTC

Update

We just sent an alert out to the game letting everyone know that we're going to reboot affected servers.
Posted Aug 21, 2026 - 06:07 UTC

Investigating

We are currently investigating this issue.
Posted Aug 21, 2026 - 05:58 UTC
This incident affected: Stars Reach Production Servers.